Not able install English Duniya, in my phone, it shows that device not supported, i am using android

    You need to have android 4.1 and up to be able to use English Duniya.